Please Make Sure You Read The Forum Rules! , Thanks for registering We are glad you have chosen to be a part of our community :) Please do not use email addresses, website URLs, Skype info, or any other contact info as your Username.
  1. ObdToolUsa

  2. Martech

  3. obdresource

    obdresource.com
  4. Piwis tester II

  5. OBD Center

  6. ChiPTuninG



Post Reply 
Mechatronics problem...
08-01-2017, 19:37 PM
Post: #1
Mechatronics problem...
Hello Guys,

Hope someone can help me. Got a rare problem. I can't get my car out of park. (335d 2007). When i read failures on EGS i get 4A86 and 5015. When i erase those codes, i can get it of park and drive normally. But when the car goes asleep, and then i wanna drive same problem again. Have to erase faultcodes everytime. Problem is that the interlock and shiftlock don't get 12v from the mechatronic. Checked wiring no problems. I measered the resistance of the shiftlocks also good. So i decided to replace the whole transmission complete. After that problem solved. But no couple of months later, same problem!?!!?!?devil Did check everything again, and it seemed mechatronics broke down again. Can someone give me advise? Am i missing something? Is the electronic part of mechatronics repairable? Why two times in a row?

Thanks...
Find all posts by this user
Quote this message in a reply
08-01-2017, 22:57 PM
Post: #2
RE: Mechatronics problem...
Was it replaced by renovated gearbox ? thoose mecatronic gearboxes has a bad reputation !
Find all posts by this user
Quote this message in a reply
09-01-2017, 07:36 AM
Post: #3
RE: Mechatronics problem...
(08-01-2017 22:57 PM)ziggystardust Wrote:  Was it replaced by renovated gearbox ? thoose mecatronic gearboxes has a bad reputation !

Used gearbox with low mileage...
Find all posts by this user
Quote this message in a reply
09-01-2017, 11:58 AM
Post: #4
RE: Mechatronics problem...
I have read about renovated mecatronics they renovate 6-gear mecatronic's for sure , send them a mail and ask .
http://www.actronics.eu/sv/dsg
hope it will help u !
Find all posts by this user
Quote this message in a reply
10-01-2017, 21:17 PM
Post: #5
RE: Mechatronics problem...
Did you deleted after installation of transmission the settings
Find all posts by this user
Quote this message in a reply
10-01-2017, 21:51 PM
Post: #6
RE: Mechatronics problem...
(10-01-2017 21:17 PM)leo04 Wrote:  Did you deleted after installation of transmission the settings

Yep, did a software update, and coded it.... Drove a few months without problems, now it is back..... Stuck in P...
Find all posts by this user
Quote this message in a reply
12-01-2017, 16:11 PM
Post: #7
RE: Mechatronics problem...
Problem is the megatronic.

If my post helped you hit the thanks and reputation button
Find all posts by this user
Quote this message in a reply
14-01-2017, 20:43 PM
Post: #8
RE: Mechatronics problem...
(12-01-2017 16:11 PM)Fx82 Wrote:  Problem is the megatronic.

Get it... but why two times in a row?
Find all posts by this user
Quote this message in a reply
14-01-2017, 23:50 PM
Post: #9
RE: Mechatronics problem...
Did you move the megatronic from the old gearbox to the new one?

If my post helped you hit the thanks and reputation button
Find all posts by this user
Quote this message in a reply
15-01-2017, 21:19 PM
Post: #10
RE: Mechatronics problem...
(14-01-2017 23:50 PM)Fx82 Wrote:  Did you move the megatronic from the old gearbox to the new one?

No, replaced it completly....
Find all posts by this user
Quote this message in a reply
Post Reply 


Bookmarks

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
XZBMW Solved ✔ Cic - problem with maps update - MOTION in poland26 9 442 15-01-2017 09:37 AM
Last Post: poland26
XZBMW Very strange problem with E70 X5 2010 after programming. in Czozen 13 750 16-12-2016 21:06 PM
Last Post: Czozen
XZBMW E89 - Very weird electrical problem in BBriner 4 443 12-12-2016 21:11 PM
Last Post: cezar202001
  F06 Comfort seats retrofit problem in masa52 0 145 12-12-2016 18:28 PM
Last Post: masa52
XZBMW HELP NEEDED ABOUT NBT NAVI PROBLEM (solved) in retrobmwtr 5 417 17-11-2016 14:38 PM
Last Post: retrobmwtr
XZBMW Video TV Module Hybrid FBAS retrofit - antennas problem in benefic 1 250 15-11-2016 07:22 AM
Last Post: brianziho
  E90 lci lights retrofit problem in haty 2 259 13-11-2016 10:25 AM
Last Post: haty
  2009 Mini R56 idle problem engine light on in koziol 0 154 10-11-2016 03:08 AM
Last Post: koziol
XSMini MINI R56 NEW DME N18 programing problem in shintake 3 223 03-11-2016 13:47 PM
Last Post: OKCZ
XZBMW E60 LCI CCC in pre LCI model - problem in cursor 3 353 14-10-2016 21:14 PM
Last Post: zeronoo

Forum Jump:


User(s) browsing this thread:
1 Guest(s)

Return to TopReturn to Content