Please make sure you read Rules! and DO NOT upload/post any illegal softwares or Pirated Material , Thank you for understanding :)
  1. AutoHex II

  2. FemtoEVO



HU_NBT2 flashing fails without useful information
12-01-2019, 19:09 PM, (This post was last modified: 12-01-2019, 19:11 PM by vilord.)
Post: #1
HU_NBT2 flashing fails without useful information
I am in the process of updating an HW3.2 evo from J16383I (2017-02?) to 2018-07.
I am working on a bench, with a ZGW2. I've flashed the ZGW2 with an updated FA including the VIN, type and VO for the car the HU_NBT2 came from (I don't have access to anything else from the HU_NBT2's vehicle).

I'm running e-sys 3.27.1, with 4.13.14 PsdZData. Flashing worked fine for the ZGW2.
When I try to run the TAL execution, updating the blFlash, swDeploy, cdDeploy, and ibaDeploy for the HU_NBT2, the evo screen goes black, the progress indicates:

preparevehicleforflash started
preparevehicleforflash finished

and then the time left goes from 35 minutes to 1 minute, and it eventually comes back FinishedWithError, but has nothing else in the log to indicate what happened (or didn't).

I have a DHCP server running, using connection type gateway connection, target F020_18_07_531_V_005_005_000, Connection via VIN.

Anyone have any ideas?

The vehicle was built 2016-11-4, I guessed the shipping i-step as F020-16-07-506, since there's no way to read the i-step from the nbt directly
Quote this message in a reply
12-01-2019, 19:52 PM,
Post: #2
RE: HU_NBT2 flashing fails without useful information
What the ip zgw and What the ip HU

NBTEVO ALPINE and HARMAN - activation Navi, CarPlay , CarPlay Full Screen , APPS , Video in motion
for ASIA, CHINA, JAPAN, EU, US regions.
HU-MGU -  already Video in motion.

for ASIA, CHINA, JAPAN, EU, US regions.

Quote this message in a reply
12-01-2019, 20:07 PM, (This post was last modified: 12-01-2019, 20:08 PM by vilord.)
Post: #3
RE: HU_NBT2 flashing fails without useful information
zgw is 172.16.1.101, HU is 172.16.1.104, e-sys is 172.16.1.102

should i try changing them all to be 169.254.199.x?
Quote this message in a reply
12-01-2019, 20:12 PM,
Post: #4
RE: HU_NBT2 flashing fails without useful information
It have to work

NBTEVO ALPINE and HARMAN - activation Navi, CarPlay , CarPlay Full Screen , APPS , Video in motion
for ASIA, CHINA, JAPAN, EU, US regions.
HU-MGU -  already Video in motion.

for ASIA, CHINA, JAPAN, EU, US regions.

Quote this message in a reply
12-01-2019, 20:59 PM, (This post was last modified: 12-01-2019, 21:28 PM by vilord.)
Post: #5
RE: HU_NBT2 flashing fails without useful information
Tried with e-sys 3.30.1 instead of 3.27.1. Instead of saying FinishedWithError, it says "Medium in dvd drive. Flash may have problems when updating drive firmware. Please remove medium from drive before flash"

So... apparently the problem is there's something in the drive. So glad that 3.30 has better error messaging!
If only I had an eject button on my coding bench... now to see if I can find the right CAN bus message to send to trigger an eject. Wheee!

Ejected the disk with tool32's STEUERN_ROUTINE command: ARG;STEUERN_EJECT;STR;04


Attached Files Thumbnail(s)
   
Quote this message in a reply
13-01-2019, 02:29 AM,
Post: #6
RE: HU_NBT2 flashing fails without useful information
Programming complete! I now have a fully functional touchscreen 10.25" NBT evo with ID6 biggrin
e-sys is only a little of a pain in the rear.
Quote this message in a reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  NBT stuck while flashing - bricked ? rickynguyen 6 327 26-04-2019, 16:35 PM
Last Post: BugFix
XZBMW F30 328i US flashing ASCM Fatalix 1 123 18-04-2019, 06:19 AM
Last Post: Fatalix
  Flashing NBT evo problem - recognize id4 vs id5 rickynguyen 15 899 17-04-2019, 21:33 PM
Last Post: Jartsa
  Nbt Evo Dead After Flashing graphys 18 1,640 17-04-2019, 05:55 AM
Last Post: ahmedmph
XZBMW BMW iRAP Session. Information SweetBMW 45 8,085 13-04-2019, 06:19 AM
Last Post: alb3rt
  E-sys flashing nbt http server error Fx82 14 894 28-03-2019, 08:32 AM
Last Post: Fx82
  Bmw f30 led ecu fle flashing Trys2penki 3 215 27-03-2019, 22:48 PM
Last Post: kubixix
XZBMW BMW E90 CIC Flashing error Czozen 5 329 27-03-2019, 18:03 PM
Last Post: atomantmk
XZBMW Very slow EVO flashing gvitkis 18 2,898 20-03-2019, 18:55 PM
Last Post: sahiljain22
XZBMW Flashing ZGW 1 to ZGW 2 & CIC & NBT bench test, Please help nguyennhatquang 37 19,686 16-03-2019, 07:10 AM
Last Post: vasya

Forum Jump:


Users browsing this thread:
1 Guest(s)

Return to TopReturn to Content