Please make sure you read Rules! and DO NOT upload/post any illegal softwares or Pirated Material , Thank you for understanding :)
  1. AutoHex II

  2. FemtoEVO



F10 535D STM disconnected due to shorted PDC
17-04-2019, 18:24 PM, (This post was last modified: 17-04-2019, 18:25 PM by Alchemist85.)
Post: #1
F10 535D STM disconnected due to shorted PDC
Hello everyone and thanks in advance.
 
My car had the left headlight module replaced twice:
First due to a crash, headlight was missing and new STML was installed and coded.
Second time 2 weeks later the headlight was cracked and got full of water. So I installed and coded a used module which worked perfectly until….
 
I pluged a OEM PDC sensor on the front left side. This caused both STM modules to lose connection.
 
Gave the following codes: 
                                       800FC8 Lin bus, headlight driver module (TMS), Left: comunication Fault
                                       800FC9 Lin bus, headlight driver module (TMS), Right: comunication Fault
                                       805D04 LIN defective
                                       805E84 LIN defective
 
Based on this thread: https://cartechnology.co.uk/showthread.p...010&page=2
FRM can go bad due to 12v being shorted and the headlight being under water. So it looks like I will need another FRM3
 
What is concerning is that seemingly plugin in a single OEM PDC sensor replacing a Chinese one, in line with 3 other Chinese ones in the front seems to have caused the fault with the FRM and STML.
 
Additionally I recently replaced the JBE precicely hoping to fix my “park assist unavailable please park unaided” message. After replacing my JBE v3 with a JBE v5 I got the following codes for the first time permanently.
 
                                         80322E Front left ultrasonic sensor, signal line: short circuit to earth or open circuit (for each one of the PDC sensors)
 
would like to replace the FRM but concerned there might be an active short in either the Chinese pdc’s or the PDC harness I purchased (I had to pick 1 out of 30 versions and not sure I got the right one)

Just to make things more interesting, Im not sure if my car came with a radiator shutter. As the previous crashed radiator did not have a solenoid, but my car’s build sheet says it came with CO2 package. So I got a radiator with a shutter and attempted to retrofit the harness to connect the shutter. Unfortunately I was not able to actuate it trough ISTA it gave an error. So not sure what is going on, I disconnected the shutter and the pdc and fog lights for now just to trouble shoot. Still STML no communication. Fuses appear to be fine.
 
 
        Cliff notes:
                        1 PDC  and stml not working and replaced.
                        2 JBE replaced = triggered short circuit pdc fault on all front sensors
                        3 Connecting OEM PDC causes both STM modules to lose connection and trigger FRM fault.
                        4 FRM to be replaced next, concern for possible existing short circuit.
 
Where to go from here? all suggestions are welcome.
Quote this message in a reply


Possibly Related Threads...
Thread Author Replies Views Last Post
XZBMW E61 engine swap 530d -> 535d pblomx 0 83 21-03-2019, 18:41 PM
Last Post: pblomx
  E46 -Interior lights stay on with battery negative disconnected! willisodhiambo 5 1,325 05-01-2018, 12:27 PM
Last Post: willisodhiambo
  Buying tips on N57Z engine 535D Fx82 0 402 27-05-2017, 10:26 AM
Last Post: Fx82

Forum Jump:


Users browsing this thread:
1 Guest(s)

Return to TopReturn to Content