Please make sure you read Rules! and DO NOT upload/post any illegal softwares or Pirated Material , Thank you for understanding :)
  1. Martech



Stuffed up MMI 3g+ Region Change
12-05-2019, 08:15 AM,
Post: #1
ZTAudi  Stuffed up MMI 3g+ Region Change
Hi all, I've got a jap import 2012 Q7 with MMI 3g+ where i've changed region settings and accidently rebooted the MMI intead of just exiting and going to the firmware update and updating from there (changed from system/internal region from JAP to ROW).

Unfortunately now I can't get back into the green menu to fix it/force the firmware update as the device won't load past the logo screen.  Buttons all seem to work (apart from main dial and soft buttons), i can switch between radio, jukebox and play songs using DIS.  The reverse camera doesn't show either.

Is there anywhere/anyhow where I can either;
  • reset the internal system region using VCDS, VCP, or an sdcard boot script
  • reset the MMI completely so it reads and re-configures itself from the build list (simliar to how BMWs do it)
  • force the update to ROW firmware without having access to the green menu (fail forwards wink
I'd rebooted when it was on internal region ROW (changed rom JAP) and nav region still on JAP.  This caused the MMI to write the following to the SD card in SD1.

Code:
Database info 01/01/70.00:06:55

no valid acios_db found on DVD-drive
--------------------------------------
no valid acios_db found on HDD
--------------------------------------
no valid acios_db found on SD0
--------------------------------------
no valid acios_db found in HBpersistence
--------------------------------------
currently used configuration:
/HBpersistence/navi/db
--------------------------------------
currently used mapstyle:
no info found. Link points to:

--------------------------------------
mapstyle versions:
--------------------------------------



I've found somewhere VCDS where the nav map region can be set so I've changed that to EUR.  That seemed to have stopped the writing of the above message and now I get the following in faults (previously I got some communication fault error) instead.  It seems like progress, but it's still stuck on the boot screen.

Code:
1 Fault Found:

03675 - Navigation Data Not Present

Any help would be much appreciated as I've now pissed the wife off to no extent!

Thanks
Quote this message in a reply
13-05-2019, 20:47 PM,
Post: #2
RE: Stuffed up MMI 3g+ Region Change
can U read eeprom by vcp?
Quote this message in a reply
14-05-2019, 10:38 AM,
Post: #3
RE: Stuffed up MMI 3g+ Region Change
Yup I can, vcds vcp still work when connecting. Can even run scripts from the sd card.
Quote this message in a reply
15-05-2019, 14:36 PM,
Post: #4
RE: Stuffed up MMI 3g+ Region Change
read eprom.when change dump.write it back.when write eu flash
Quote this message in a reply
17-05-2019, 08:37 AM,
Post: #5
RE: Stuffed up MMI 3g+ Region Change
hi, challenge is i can't boot into the menus to start the flash. Will changing the eeprom language sort it out? will give it a punt
Quote this message in a reply
18-05-2019, 01:28 AM,
Post: #6
RE: Stuffed up MMI 3g+ Region Change
Hmm adding in en_GB didnt help , will have to pull it out to get ipl boot and see from there
Quote this message in a reply
19-05-2019, 09:26 AM,
Post: #7
RE: Stuffed up MMI 3g+ Region Change
sussed it in the end.  for anyone else who ends up in a simliar situation.  long story short the MMI seemed to be unable to boot due to unknown fonts (or so the errors told me once i sucked all the files off using SD card scripts).  Changing the eeprom to include en_GB itself didn't solve it so I;
- updated the eeprom to include en_GB and de_DE (just added to the end of the language list), to do that I;
   - used VCP to read, login code 21055
   - read from 4096, length 8192
   - saved the file, and edited the file by adding en_GB and de_DE after JP languages (as per here https://www.audienthusiasts.com/Infotain...EPROM.html)
     - make sure you're overwriting the whitespace, not adding to the file length
     - it's likely the whole lot shoud be changed as per the above link but I managed to get it going by just adding en_GB and de_DE to the end so am going to just leave as is
     - it's likely important to include de_DE as at some point my DIS switched to German and when the MMI came back to life it was in German (figure if I didn't have de_DE here I'd have pretty much the same situation as I started with)
 - I also deleted the contents of the swdl folder as recommended by someone on a translated russian forum for someone having a similar problem to me (specifically the region.txt.z file)
 - I then connected to the MMI using the serial port on the side of the motherboard. This wasn't as hard as it sounds, to do that I;
   - followed the instructions here (https://www.scribd.com/doc/225614389/How...or-3G-Plus)
   - bought a cheap USB to serial device with FT232 chipset (one for ardunio seems to do the trick, cost 16NZD)
   - soldered the wires on the motherboard (a card connector would've been nice but i couldn't find one)
     - if you can find a card connector instead then there's a metal punch out on the side of the unit you could likely push out (will need the lid off to shake it out though) so you don't have to take it all apart
     - put header pins on the end of the wires and plugged into the arduino board
     - fired up putty over serial using the specs in the doc, once putty loaded i didn't get a prompt until i pressed 'enter' so give that a go if you don't think it's working
   - once that was confirmed working I;
     - rebooted into IPL mode by holding the GRND and RX header pins together as it booted
     - booted into the emergency loader as per the doc
     - stopped it from rebooting itself as per the doc
     - note: you may or may no have anything on the audi screen here, this doesn't matter as all the interesting stuff is happening on the putty terminal window
     - copied the flash files across as per the doc, using the firmware I got here https://www.a5oc.com/forums/a5-general-q...ation.html
     - note: the doc talks about different versions (9411, 9498), dependent on the file you download it will have either one or the other, not both
     - looking in my log file both codes were mentioned so i was confused, the file only had one though and that seemed to work OK
     - other note: my SD Card 1 was actually sdcard10t12, not sdcard10t11 (you can 'ls' through mnt to see what's why')
     - I used the modified firmware with user defined mode, no stereo updates, and green menu enabled. apparently you can bork the bose system if you update it so best to be cautious smile
  - after all the flashing I rebooted and the device came up ,although in German  (Yay!)
  - all the firmware files though said it was the japanese firmware, so i went into the engineering mode (CAR + RETURN) and ran the system upgrade from there
  - that took a while with a few reboots and installed a bunch of stuff that likely wasn't there (mainly speech languages etc)
  - at the end I cancelled on installing documentation as suggested, and when it rebooted it was good to go
  - after this reboot it took some time (minutes) for it to all come together (juxebox was missing for a while, settings were grayed out etc) but it eventually got there and I was able to change the language to english GB and it was all good to go!

So it's up and running which is awesome, there's no maps but that's not a drama as I haven't come across any NZ maps for it yet.  Now that it's all switched across to EU ROW firmware, setting and updating maps shouldn't be too much of a drama.
Quote this message in a reply
[+] 1 user says Thank You to scottjjr for this post
21-05-2019, 05:59 AM,
Post: #8
RE: Stuffed up MMI 3g+ Region Change
Excellent write-up scottjjr! Glad you sorted it out in the end.  clapping

Maybe place the docs in an attachment so it doesn't get lost when an URL changes?  wink
Quote this message in a reply


Possibly Related Threads...
Thread Author Replies Views Last Post
XZBMW BMW enabling code needed after radio change fiz_lth 6 312 14-08-2019, 13:47 PM
Last Post: fiz_lth
  Solved ✔ Becker radio BE4730 traffic pro eeprom /pin location need to change code dil6222 6 316 26-07-2019, 10:20 AM
Last Post: dil6222
YTMercedes w222 change language to Arabic Basheerosama 0 224 25-07-2019, 17:40 PM
Last Post: Basheerosama
0Radio RCD510 Delphi language change gordonpl93 0 216 18-07-2019, 15:41 PM
Last Post: gordonpl93
XZBMW NBT EVO radio and navigation change from North America to middle east Basheerosama 1 265 15-07-2019, 05:28 AM
Last Post: dr.aws
VLexus Change fahrenheit to celsius and map upgrade lexus 4GS nitro3241 0 201 22-06-2019, 17:37 PM
Last Post: nitro3241
YTMercedes Mercedes W204 Change Language Anass GM 0 257 11-06-2019, 01:28 AM
Last Post: Anass GM
ZTAudi MMI 2G How to Change Language atomantmk 0 270 10-06-2019, 10:11 AM
Last Post: atomantmk
ZVW RNS850 How to do Conversion or Change Map From US to EU atomantmk 7 2,032 07-05-2019, 20:36 PM
Last Post: cultos
  Question about change cid on cards barto39 2 234 04-04-2019, 10:00 AM
Last Post: barto39

Forum Jump:


Users browsing this thread:
1 Guest(s)

Return to TopReturn to Content