1. AutoHex II

  2. FemtoEVO

  3. AUTO CHIPS



BMW Unable to wake up NBT on bench
15-02-2020, 08:44 AM,
Post: #1
XZBMW  BMW Unable to wake up NBT on bench
Hi there,

I have here a NBT head unit from a M5 (2013/06) on my bench and I am not able to wake it up. sad

In my setup I have a black ZGW (1), IHKA3, ZBE3 and a Chinese CAS 4 emulator. As a replacement, but actual not in use, I  have an Arduino Shield CAN gateway

When the NBT gets power, I briefly see the splash screen, then it goes dark.
I suspect that the CAS4 emulator sends the wrong codes.

With the Arduino I already trieed to send this codes:
ID 0x12F 37 7C 8A DD D4 05 33 06
ID 0x130 45 40 22 8F FE

Unfortunately without success.
Do you have another tip for me how I can get the NBT woken up?
Quote this message in a reply
15-02-2020, 08:55 AM,
Post: #2
RE: BMW Unable to wake up NBT on bench
NBT works even without ZGW on bench if your emulator is sending the right wakeup signal. ZGW is used only for flashing .

ZGW1 doesn't work with NBT unless you flash it to ZGW2 ( unless you have done that already ).

when you say Chinese CAS 4 emulator , which one are you referring to ? .
Quote this message in a reply
15-02-2020, 09:21 AM,
Post: #3
RE: BMW Unable to wake up NBT on bench
Hi there,
I already had the ZGW on ZGW2, but then I no longer see the HU in the Esys, only on ZGW1.

Before the question comes, the HWEL from the HU is DF6, that from the ZGW 925

The emulator was included in a cable set: https://www.aliexpress.com/snapshot/0.ht...2711394486
It says CAS Emulator for NBT
Quote this message in a reply
15-02-2020, 10:48 AM,
Post: #4
RE: BMW Unable to wake up NBT on bench
i can't open the link in Europe . but if you are able to see ZGW that means emulator is working fine .

if NBT is not showing in the list then maybe you didn't connected the ethernet socket to ZGW or connected it incorrectly .

you need to check wiring diagram and compare it with your cable set
Quote this message in a reply
15-02-2020, 13:28 PM,
Post: #5
RE: BMW Unable to wake up NBT on bench
I think cableing is fine. I have a view seconds, there I see the nbt in the ecu list in Esys. Then it is pingable as well. In tool32 same. I see the nbt a view seconds till it goes to sleep (I assume)
And I agree emulator seems to work. If I switch it off, There is no splash screen while powering on nbt.
With Emulator I see the splash screen.
I think there is missing a can message. But which is the question....
Quote this message in a reply
15-02-2020, 20:49 PM,
Post: #6
RE: BMW Unable to wake up NBT on bench
Now I found the reason: In addition to CAN and Ethernet, I had connected MOST between ZGW(1) and HU. Result: Only splash screen, after splash HU went to sleep.

When the MOST Cable is disconnected HU is starting as expected laughing

Now I did flash to ZGW2. When MOST is connected, HU is running but disappears from ECU list of Esys after a view seconds.
When I disconnect MOST, HU is running and ECU stays in ECU list, everything is fine.

It's only cosmetical, but do I have to configure somewhat aditional to have a working MOST connected to ZGW?
Quote this message in a reply
15-02-2020, 21:30 PM, (This post was last modified: 15-02-2020, 21:31 PM by Jalami.)
Post: #7
RE: BMW Unable to wake up NBT on bench
I have finished making the bench wiring.  Where to buy, recommend an emulator ignition can bus  (for benck)???
Quote this message in a reply
16-02-2020, 11:04 AM,
Post: #8
RE: BMW Unable to wake up NBT on bench
I found two filters.

Can anyone recommend me any? for bench


Attached Files
can emulator.txt
File Type: .txt
Downloaded: 18 times
Size: 74 bytes

Quote this message in a reply
16-02-2020, 11:43 AM,
Post: #9
RE: BMW Unable to wake up NBT on bench
https://cartechnology.co.uk/showthread.php?tid=52726

!!! NBTEVO support all I-levels including 19-11-XXX !!!
NBTEVO - Navi, CarPlay , CarPlay Full Screen , APPS , Video in motion
NBTEVO - Region change / black screen unlock
HU-MGU ID7Video in motion.





Quote this message in a reply
[-] The following 1 user says Thank You to BugFix for this post:
  • Jalami
16-02-2020, 14:00 PM,
Post: #10
RE: BMW Unable to wake up NBT on bench
What kind of Emulator you like to use? Via USB or a Chinese Blackbox, with fixed output?
Quote this message in a reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  E-sys Launcher Pro 3.7 unable to activate static mjuhl2003 10 1,029 03-02-2020, 17:08 PM
Last Post: mjuhl2003
  DME 5.2.1 bench flashing with Winkfp? Spirit5676 3 228 27-01-2020, 07:38 AM
Last Post: o-dog
  Bench Coding - Need help on required components TokenMaster 32 3,867 10-01-2020, 05:56 AM
Last Post: lustek
  Bench testing DISA valves. sickfinga 9 462 08-01-2020, 22:21 PM
Last Post: dil6222
  Component Protection NBT EVO Bench Flashing Jesuspenamdn 3 443 07-01-2020, 17:06 PM
Last Post: Jesuspenamdn
  bench emu for f series Silva1337 0 300 04-01-2020, 17:25 PM
Last Post: Silva1337
  ATM - NBT EVO - bench stup - help needed Wibbles 55 6,525 03-01-2020, 17:39 PM
Last Post: dezihh
XZBMW cas / cluster bench setup Cniksor 95 16,444 28-12-2019, 22:50 PM
Last Post: ericM1960
  NBT flash fail in car and on bench also darthur90 13 1,046 18-12-2019, 00:24 AM
Last Post: bmwmania
  Solved ✔ 335xi 2010 no wake up mrrichje 3 187 04-12-2019, 08:18 AM
Last Post: mrrichje

Forum Jump:


Users browsing this thread:
1 Guest(s)

Return to TopReturn to Content