Please make sure you read Rules! and DO NOT upload/post any illegal softwares or Pirated Material , Thank you for understanding :)
  1. AutoHex II

  2. FemtoEVO



HU_NBT2 flashing fails without useful information
12-01-2019, 19:09 PM, (This post was last modified: 12-01-2019, 19:11 PM by vilord.)
Post: #1
HU_NBT2 flashing fails without useful information
I am in the process of updating an HW3.2 evo from J16383I (2017-02?) to 2018-07.
I am working on a bench, with a ZGW2. I've flashed the ZGW2 with an updated FA including the VIN, type and VO for the car the HU_NBT2 came from (I don't have access to anything else from the HU_NBT2's vehicle).

I'm running e-sys 3.27.1, with 4.13.14 PsdZData. Flashing worked fine for the ZGW2.
When I try to run the TAL execution, updating the blFlash, swDeploy, cdDeploy, and ibaDeploy for the HU_NBT2, the evo screen goes black, the progress indicates:

preparevehicleforflash started
preparevehicleforflash finished

and then the time left goes from 35 minutes to 1 minute, and it eventually comes back FinishedWithError, but has nothing else in the log to indicate what happened (or didn't).

I have a DHCP server running, using connection type gateway connection, target F020_18_07_531_V_005_005_000, Connection via VIN.

Anyone have any ideas?

The vehicle was built 2016-11-4, I guessed the shipping i-step as F020-16-07-506, since there's no way to read the i-step from the nbt directly
Quote this message in a reply
12-01-2019, 19:52 PM,
Post: #2
RE: HU_NBT2 flashing fails without useful information
What the ip zgw and What the ip HU

NBTEVO ALPINE and HARMAN for any software version !!! - activation Navi, CarPlay and CarPlay Full Screen , APPS and Video in motion for ASIA, CHINA, JAPAN, EU, US regions.
Quote this message in a reply
12-01-2019, 20:07 PM, (This post was last modified: 12-01-2019, 20:08 PM by vilord.)
Post: #3
RE: HU_NBT2 flashing fails without useful information
zgw is 172.16.1.101, HU is 172.16.1.104, e-sys is 172.16.1.102

should i try changing them all to be 169.254.199.x?
Quote this message in a reply
12-01-2019, 20:12 PM,
Post: #4
RE: HU_NBT2 flashing fails without useful information
It have to work

NBTEVO ALPINE and HARMAN for any software version !!! - activation Navi, CarPlay and CarPlay Full Screen , APPS and Video in motion for ASIA, CHINA, JAPAN, EU, US regions.
Quote this message in a reply
12-01-2019, 20:59 PM, (This post was last modified: 12-01-2019, 21:28 PM by vilord.)
Post: #5
RE: HU_NBT2 flashing fails without useful information
Tried with e-sys 3.30.1 instead of 3.27.1. Instead of saying FinishedWithError, it says "Medium in dvd drive. Flash may have problems when updating drive firmware. Please remove medium from drive before flash"

So... apparently the problem is there's something in the drive. So glad that 3.30 has better error messaging!
If only I had an eject button on my coding bench... now to see if I can find the right CAN bus message to send to trigger an eject. Wheee!

Ejected the disk with tool32's STEUERN_ROUTINE command: ARG;STEUERN_EJECT;STR;04


Attached Files Thumbnail(s)
   
Quote this message in a reply
13-01-2019, 02:29 AM,
Post: #6
RE: HU_NBT2 flashing fails without useful information
Programming complete! I now have a fully functional touchscreen 10.25" NBT evo with ID6 biggrin
e-sys is only a little of a pain in the rear.
Quote this message in a reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  E-sys flashing nbt http server error Fx82 12 469 18-03-2019, 16:02 PM
Last Post: Fx82
XZBMW Flashing ZGW 1 to ZGW 2 & CIC & NBT bench test, Please help nguyennhatquang 37 17,905 16-03-2019, 07:10 AM
Last Post: vasya
XZBMW BMW iRAP Session. Information SweetBMW 43 6,787 13-03-2019, 19:49 PM
Last Post: poppiraver
  Solved ✔ Coding Info for FULL LED Headlights information fixityourself 4 353 13-03-2019, 04:00 AM
Last Post: fixityourself
XZBMW Information for the validation of ECUs with ISTA // Info // german chang2 0 170 07-03-2019, 22:43 PM
Last Post: chang2
XZBMW Flashing AT-->MT DDE7 turbodieselro 10 427 01-03-2019, 00:41 AM
Last Post: jamam5
  Nbt Evo Dead After Flashing graphys 13 974 27-02-2019, 15:48 PM
Last Post: rickynguyen
  Flashing G series EVO HW4.1 Wibbles 2 344 21-02-2019, 06:50 AM
Last Post: Wibbles
XZBMW Very slow EVO flashing gvitkis 17 2,435 18-02-2019, 12:08 PM
Last Post: rickynguyen
  CIC winkfp flash comfort and expert fails Freddy1 5 391 16-02-2019, 09:26 AM
Last Post: Freddy1

Forum Jump:


Users browsing this thread:
1 Guest(s)

Return to TopReturn to Content